WordPress3.7 “Basie”发布

状态

目前wordrpess3.7版本已经发布了,不过中文版暂时还没有更新,此版本更新是为3.8的自动更新做准备,并且加强了密码强度检测,以及全球化语言支持,更新后在后台更新面板可以看到更新语言文件提示。 目前我已经更新,你更新了么? wordpress3.7更新,为3.8做准备
点击阅读全文

无插件实现代码高亮 – wowcode

  代码高亮似乎是很多博主都在纠结的问题。使用插件的确方便,不过会影响博客的加载速度,对于不使用插件的方法,现在很多朋友使用的是发芽网提供的代码高亮功能。不过呢,每次都需要打开网站去高亮代码然后复制回来,似乎比较麻烦。于是,李道然童鞋就自己搞了个软件“wowCode”来实现代码高亮。WowCode是一个高亮代码本地生成器,可以让你免去加载那些高亮代
点击阅读全文

给wordpress加上QapTcha验证

关于QapTcha这个东东,很好玩,很有效。QapTcha是一个利用jQuery UI实现,易于使用,简单并且直观可拖动的jQuery Captcha系统。它让用户拖动一下来代替输入不易看清的验证码。我们可以利用它来实现验证码功能,抵御垃圾评论。 不过对于将QapTcha这东西集成到wordpress的介绍很少,目前看到好几位wper已经用上了,其中几位都是loper付费主题用户,通过google只搜索到了一篇文章,而且我
点击阅读全文

WP Minify 插件常见错误解决方案

因为之前不能评论的原因,我已经取消了WP Minify插件的使用。不过今天在网上瞎晃的时候,却发现了企鹅君写的一篇关于WP Minify使用的文章,其中不仅完整的解释了WP Minify的设置,还列出了WP Minify插件可能出现的错误以及解决方法。 WP Minify 是WordPress中相当实用的一个插件,作者这几天疯狂更新,目前最新版本是1.1.6。实质上将minify引擎变为了一个使用更为简便和自动化的插件,
点击阅读全文

防止攻击 – WordPress登录邮件提醒

WordPress 不像Dedecms,可以任意的修改后台管理目录文件夹的文件名,防止有人恶意穷举登陆来破解密码。随着 WordPress 的发展,关注的人越来越多,漏洞也越来越多,我们更应该注意自己的后台安全。 为了防止博客被人穷举登陆,我们可以使用下面的代码来自动发送邮件提醒自己。 首先需要确定的是空间有无邮件功能,此功能需要邮件功能支持,测试有无邮件功能的方法:登录
点击阅读全文

选择合适的jQuery加载源,加速你的网站

目前大量的网站都使用了jQuery来实现各种特效,wordpress也在2.8版本引入了jQuery库。不过随着jQuery的不断发展,文件是越来越大了,烙印现在使用的jquery.min.1.4.4.js文件已经达到76K之巨。对于我们广大的独立博客来说,因为网络环境的因素,很多朋友都安家国外,所以从空间加载这东西压力很大。并且流量对于和我一样使用虚拟主机的童鞋来说,是相当宝贵的。 所以,为了节约流
点击阅读全文

WordPress更新至3.1.2 修复安全漏洞

WordPress 3.1.2版本已经发布,在后台管理面板已经可以看到自动更新提示。这是一次安全更新,建议所有的用户都尽快升级到新版本。以下是WordPress官方的声明:WordPress 3.1.2 已经发布,这是针对先前所有版本的一次安全更新。 此版本解决了一个允许贡献者(Contributor-level)身份用户不当地发布日志的安全漏洞。 这个问题是由我们安全小组的成员Andrew Nacin和Benjamin Balter发现的,他
点击阅读全文

页面载入进度条

Microhu同学刚刚把这个东西搞上,其实我也很早就在ZWWoOoOo的付费主题中看到过了。不过一直自己的主题没地方放,二是懒得动手,所以一直没有捣鼓过。不久前在Dianso童鞋那里偷了现在顶部那东东,所以也算有个位置放进度条了,好吧,我也加上玩玩。 不过对于代码,Microhu童鞋很忙,还好Timothy同学已经整理出来了,所以我就是用了现成的。它的原理:在页头放置一个 loading 状
点击阅读全文